#3 – Exercícios em Linguagem C – Troca de valores

Exercícios em Linguagem C – Troca de valores

/* 
## QUESTÃO

 Ler dois valores para as variáveis A e B, e efetuar as trocas dos
 valores de forma que a variável A passe a possuir o valor da
 variável B e a variável B passe a possuir o valor da variável A.
 Apresentar os valores trocados  
	
	Exemplo.:
	A = 10 e B= 5.... A=5 e B=10.... 
*/

//Obs.: Retire os espaços dos includes
#include< stdio.h >
#include< stdlib.h >
#include< locale.h > /* Acentuação */

void main()
{
	//Acentos no prompt de comando Windows 
	setlocale(LC_ALL, "Portuguese");
	 
	//Variaveis
	int A, B, AUX;
	
	//ENTRADA
	printf("Entre com o valor de A: ");
	scanf("%d", &A);
	printf("Entre com o valor de B: ");
	scanf("%d", &B);
      
	//PROCESSAMENTO
	AUX = A;
	A   = B;
	B   = AUX;
	
	//SAIDA
	printf("O novo valor de A é: %d \n", A);
	printf("O novo valor de B é: %d \n", B);
 		
	system("pause");
}
/* 
## EM VISUALG

algoritmo "Ex 3"

var
     A, B, AUX :inteiro
inicio

      //ENTRADA
      escreva("Entre com o valor de A: ")
      leia(A)
      escreva("Entre com o valor de B: ")
      leia(B)
      
      //PROCESSAMENTO
      AUX <- A
      A   <- B
      B   <- AUX
      
      //SAIDA
      escreval("O novo valor de A é: ", A)
      escreval("O novo valor de B é: ", B)

fimalgoritmo


*/