#6 – Exercícios em Linguagem C – Qual maior número

Verifica se o valor 1 é maior que o 2 e vice versa – www.netocortes.com.br

 

/* 
## QUESTÃO

Escrever um fluxograma que leia dois valores
inteiro distintos e informe qual é o maior.

*/

//Obs.: Retire os espaços dos includes
#include< stdio.h >
#include< stdlib.h >
#include< locale.h > /* Acentuação */

void main()
{
	//Acentos no prompt de comando Windows 
	setlocale(LC_ALL, "Portuguese");
	
	//VARIAVEIS
	int val1, val2;
	
	//ENTRADA DE DADOS
	printf("Entre com o primeiro valor: ");
	scanf("%d", &val1);
	printf("Entre com o segundo valor: ");
	scanf("%d", &val2);
	
	//PROCESSAMENTO
	if(val1 > val2)
	{
		printf("### Primeiro valor maior que o segundo ### \n\n");
	}
	
	if(val2 > val1)
	{
		printf("### Segundo valor maior que o primeiro ### \n\n");
	}
	
	system("pause");
}
/* 
## EM VISUALG

algoritmo "Ex 6"

var
   val1, val2 :inteiro
inicio

      escreva("Entre com o primeiro valor: ")
      leia(val1)
      escreva("Entre com o segundo valor: ")
      leia(val2)
      
      se val1 > val2 entao
           escreva("Primeiro valor maior que o segundo ")
      fimse


      se val2 > val1 entao
           escreva("Segundo valor maior que o primeiro")
      fimse


fimalgoritmo
*/