#6 – Exercícios em Linguagem C – Qual maior número

Verifica se o valor 1 é maior que o 2 e vice versa – www.netocortes.com.br

 

/* 
## QUESTÃO

Escrever um fluxograma que leia dois valores
inteiro distintos e informe qual é o maior.

*/

//Obs.: Retire os espaços dos includes
#include< stdio.h >
#include< stdlib.h >
#include< locale.h > /* Acentuação */

void main()
{
	//Acentos no prompt de comando Windows 
	setlocale(LC_ALL, "Portuguese");
	
	//VARIAVEIS
	int val1, val2;
	
	//ENTRADA DE DADOS
	printf("Entre com o primeiro valor: ");
	scanf("%d", &val1);
	printf("Entre com o segundo valor: ");
	scanf("%d", &val2);
	
	//PROCESSAMENTO
	if(val1 > val2)
	{
		printf("### Primeiro valor maior que o segundo ### \n\n");
	}
	
	if(val2 > val1)
	{
		printf("### Segundo valor maior que o primeiro ### \n\n");
	}
	
	system("pause");
}
/* 
## EM VISUALG

algoritmo "Ex 6"

var
   val1, val2 :inteiro
inicio

      escreva("Entre com o primeiro valor: ")
      leia(val1)
      escreva("Entre com o segundo valor: ")
      leia(val2)
      
      se val1 > val2 entao
           escreva("Primeiro valor maior que o segundo ")
      fimse


      se val2 > val1 entao
           escreva("Segundo valor maior que o primeiro")
      fimse


fimalgoritmo
*/

#5 – Exercícios em Linguagem C – Maior que 10

Verifica se o número é maior que 10 – www.netocortes.com.br

 

/* 
## QUESTÃO

Faça um fluxograma que receba um número e mostre uma mensagem
caso este número seja maior que 10.

*/

//Obs.: Retire os espaços dos includes
#include< stdio.h >
#include< stdlib.h >
#include< locale.h > /* Acentuação */

void main()
{
	//Acentos no prompt de comando Windows 
	setlocale(LC_ALL, "Portuguese");
	
	int num;
	
	printf("Informe um número: ");
	scanf("%d", &num);
	
	if(num > 10) 
	{
		printf("Número %d é maior que 10 \n\n", num);
	}
		
	system("pause");
}

/* 
## EM VISUALG

algoritmo "Ex 5"

var
     num :inteiro
inicio

      escreva("Informe um número: ")
      leia(num)
      
      se num > 10 entao
         escreval("Número ", num, " maior que 10")
      fimse

fimalgoritmo
*/

#4 – Exercícios em Linguagem C – Prestações da compra

Efetuando o calculo da prestação com a divisão por 5 – www.netocortes.com.br

 

/* 
## QUESTÃO

A Loja Mamão com Açúcar está vendendo seus produtos em 5 (cinco)
prestações sem juros. Faça um algoritmo que receba um valor de 
uma compra e mostre o valor das prestações 

*/

//Obs.: Retire os espaços dos includes
#include< stdio.h >
#include< stdlib.h >
#include< locale.h > /* Acentuação */

void main()
{
	//Acentos no prompt de comando Windows 
	setlocale(LC_ALL, "Portuguese");
	
		//VARIAVEIS
		float val_compra, prestacao;
	
		//ENTRADA
		printf("Entre com o valor da compra: ");
	 	scanf("%f", &val_compra);
	  
		//PROCESSAMENTO
		prestacao = val_compra / 5;
		
	 	//SAIDA
      	printf("O valor de cada prestação é: %.2f \n\n", prestacao);
	 
	system("pause");
}
/* 
## EM VISUALG

algoritmo "Ex 4"

var
     val_compra, prestacao :real
inicio
      //ENTRADA
      escreva("Entre com o valor da compra: ")
      leia(val_compra)
      
      //PROCESSAMENTO
      prestacao <- val_compra/5
      
      //SAIDA
      escreval("O valor de cada prestação é: ", prestacao)

fimalgoritmo

*/